Arconix Shortcodes v1.2.0

Happy New Year everyone!

Release version 1.2.0 of Arconix Shortcodes should be live on your dashboards. While you can read the full release notes if you’re so inclined, the main draw of this release for the vast majority of users will be the addition of a “load” parameter to the toggle. The default state is closed, but when load="open", the toggle will load in the open state, and clicking the toggle’s title will slide it closed. This was a user-requested feature, so keep those requests coming!

Other updates are more developer and power user focused — replaced a deprecated javascript function for users who load jQuery 1.9.x without the migrate script, fixed a bug in the toggle shortcode’s custom CSS output and some additional filters and security restrictions around the dashboard widget and post/page meta box.

Most improvements are coming from users at this point so apply the update and provide your feedback. I’m open to all suggestions!

  • Not working 🙁

    It has stopped working on my website, now everything looks awful: (

    How I can return to the previous version?

    Thanks…

    • Hi there!

      Sorry for the troubles. I have the plugin running successfully at http://demo.arconixpc.com/arconix-shortcodes/

      Are you using any kind of caching plugins like WP Super Cache or W3 Total Cache? Those sometimes don’t always auto update when plugins are updated.

      • Yes, use WP Super Cache.

        Thanks, I fixed back to the previous version.

        Thank you very much for everything, your plugin is great 🙂

  • PUSHPAK PATEL

    Thanks for the great plugin :). I am having issue with the current version on the live site.

    throws a js error : cannot call methods on tabs prior to initialization; attempted to call method ‘div.arconix-panes > div’

    Worked fine on my local site. Can you please help me out.

    • Thank you for the kind words. Do you have a link to the live site I can look at?

      • PUSHPAK PATEL

        The issue was with the jQuery Tools CDN link. ” http://cdn.jquerytools.org/1.2.7/tiny/jquery.tools.min.js “. My site is on HTTPS and so it was not getting downloaded and so js error was coming. I found a filter in your plugin “arconix_jquerytools_reg” and used it to use the jQuery Tools file hosted on my server.

        Btw Nice Plugin and that Filter saved the day :D. thanks

  • Anon

    If running WordPress with https:// and tabs are not working, amend the PHP file – wp-content/plugins/acronix-shortcodes/plugin.php – find ‘arconix_jquerytools_reg’ , change ‘url’ => ‘https://cdn.jquerytools.org/1.2.7/tiny/jquery.tools.min.js’, to ‘url’ => get_stylesheet_directory_uri() . ‘/js/jquery.tools.min.js’,
    and paste the jquery.tools.min.js in your js theme folder – theme/js/jquerytools.min.js

    • Thank you for providing that information, though I do caution against editing plugin files directly as they will be overwritten when I update the plugin. In place of that, users looking to make such a change would be better off using a filter to modify that value. See https://gist.github.com/j-gardner/6475718 as an example